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Overview 
The Payroll Gross Data Export and Import procedures provide financial personnel with vital budgeting 

information, and allows for the transfer of salaries across years.  The procedure allows salaries to be 

“rolled”, and the necessary changes made to employees’ locations and accounts for the September 

payroll. 

 After the July payroll, users may export the existing gross data, and pull the 10-month employees’ 

information by class code and by contract months where appropriate.  At this point, PCGenesis users 

should also make the necessary updates to the applicable accounts and dollar amounts within the 

Microsoft® Excel spreadsheet.   

 After the August payroll, and after these employees’ new salary and assignments are determined, the 

spreadsheet for these employees may be imported into PCGenesis.   

This procedure also affords the following additional advantages: 

 Import the monthly Substitute pay or other special one-time pay amounts such as stipends or perfect 

attendance bonuses, and salary supplements into PCGenesis from the Microsoft® Excel spreadsheet. 

 Create and import a spreadsheet with new teachers who elect to receive their pay spread over 13 

months instead of 12 months into PCGenesis for the August payroll. 

 It is also possible to use this process for 11- and 12-month employees.  With fewer employees in 

these categories, it may be more efficient to enter these changes manually into PCGenesis. 

To comply with Teacher Retirement System (TRS) reporting requirements, the SERV (Retirement 

Service Indicator) is included in both, the import and the export files. 

Payroll Gross Data Export:  Use the export procedure as needed to create a financial analysis and 

projection spreadsheet.  The Payroll Gross Data Export procedure has two options for creating the 

export file.  The field, Export only employees with NO current gross data lines in order to set up 

import template, determines which employees are included in the export file as follows: 

 To export only employees with NO current gross data lines, select ‘Yes’.  

 To export only employees with current gross data lines, select ‘No’. 

Existing Employee Information:  Selecting the ‘No’ option allows the payroll administrator to export 

existing employees’ gross data information.  Although PCGenesis exports active employees’ 

information containing gross data entries that include hourly and daily pay, the procedure omits inactive 

employees’ information, and employees’ information without gross data information from the export.  

Additionally, PCGenesis includes ‘Z’ (Pension Adjustments) in the export’s results where appropriate. 

New Employee Information:  Selecting the ‘Yes’ option allows the payroll administrator to export gross 

data information for employees with NO current gross data lines.  This option facilitates creating a csv 

template (Excel spreadsheet) to use for setting up gross data account information for newly hired 

employees.   

For example, selecting ‘Yes’ for this option allows the csv template to be created with headers and with 

the following fields populated for each employee:  employee id, last name, first name, sequence number, 

cycle gross, state salary, local salary, other salary, contract months, number of pay periods, class code, 

TRS service indicator, pay location and work location.  However, the gross data account columns and 

corresponding fields will be blank or zero in the csv file. 
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Alternatively, newly hired employees’ information may be entered into PCGenesis before exporting the 

gross data information.  In this case, selecting the ‘No’ option allows the payroll administrator to export 

existing employees’ gross data information, even for newly hired employees.   

Payroll Gross Data Import:  Perform the Import procedure only after payroll is set up, and before F4 

(Calculate Payroll & Update YTD (FINAL).  PCGenesis also verifies the account number information to 

ensure the year is consistent throughout the entries. 

Perform the Import procedure to roll salaries for 10 month employees:  For these employees, the Import 

procedure is performed after the August payroll run(s), but before the September payroll is set up.   

The Import procedure may also be executed for the following scenarios: 

 Substitute employee’s pay:  Monthly. 

 Special Pay/Stipends:  As needed. 

 13-Pay Employee Information:  Enter thirteen-pay employees’ gross data account detail lines into 

the Microsoft® Excel spreadsheet. 

  



PCGenesis Payroll System Operations Guide 

Georgia Department of Education 

June 17, 2016  2:17 PM  Page 3 of 45 

All Rights Reserved. 

Procedure A:  Payroll Gross Data Export and Import File 

Processing Checklist 
 

√  STEP ACTION 

 1  Verify the GROSSDAT folder exists, or create the GROSSDAT folder on the C:\ drive. 

 2  Create a comma delimited format (.csv) file with the PCGenesis payroll gross data. 

The Payroll Gross Data Export process provides the user with the ability to export 

PCGenesis payroll gross data lines into a Microsoft® Excel comma delimited file 

(.csv), thus creating an import file template.   

Alternatively, a Microsoft® Excel comma delimited file (.csv) can be created via a 

spreadsheet. 

Refer to Appendix A:  Payroll Gross Data Import .csv File Layout for the comma 

delimited file (.csv) layout. 

 3  Use Microsoft® Excel to update the PCGenesis payroll gross data in the comma 

delimited file (.csv). 

 4  Process the comma delimited file (.csv) using the Payroll Gross Data Import process. 
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Procedure B:  PCGenesis to Microsoft® Excel Payroll Gross 

Data Export File Processing 

B1. Creating the PCGenesis Payroll Gross Data Export File 
Step Action 

1  Navigate to C:\GROSSDAT to verify the folder (directory) exists. 

Where appropriate, follow normal procedures to create the folder on the C:\ drive. 

2  From the Business Applications Master Menu, select  (F2 - Payroll System). 

The following screen displays: 

 

Step Action 

3  Select  (Pay Monitor), and verify the payroll is complete through F14 (Update 

Budget Files with Current Pay) is complete. 

4  Select F16 (Exit) to return to the Payroll System – Master Menu. 

5  From the Payroll System – Master Menu, select  (F13 - Special Functions Menu). 
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The following screen displays: 

 

Step Action 

6  Select  (F8 - Payroll Export/Import Menu). 
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The following screen displays: 

 

Step Action 

7  Select  (F1 - Payroll Gross Data Export). 
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The following screen displays: 

 

Step Action 

8  Verify the path and filename have defaulted correctly as C:\GROSSDAT\GROSSEXP.csv, 

or enter the correct path and filename in the Enter the Export file Path and Name field , or 

select  (F10 - Browse to select file) to browse for the correct filename. 

PCGenesis allows entries other C:\GROSSDAT\GROSSEXP.csv as long as the directory 

structure entered exists. 

In the case of duplicated filenames, PCGenesis replaces the previous file’s information with 

the most recently selected deduction and payroll information results. 

9  Select  (Enter - continue). 
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The following screen displays: 

 

Step Action 

10  Select  (F10 – Set filter condition).  Use F10 to set the filter conditions and to export the 

Gross Data information for a subset of employees.  Setting the filter criteria is optional.  Refer 

to Topic 1:  Set/Clear Employee Search Criteria for instructions on defining the record 

selection criteria. 

  

Filter options not set. 
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The following screen displays: 

 

Step Action 

11  Select the  (Radio button) to the left of the desired Export only employees with NO current 

gross data lines in order to set up import template field. 

 To export only employees with NO current gross data lines, select ‘Yes’.  

 To export only employees with current gross data lines, select ‘No’. 

The Payroll Gross Data Export option allows the payroll administrator to export gross data 

information for employees with NO current gross data lines.  This option facilitates creating a csv 

template (Excel spreadsheet) to use for setting up gross data account information for newly hired 

employees.   

For example, selecting ‘Yes’ for this option allows the csv template to be created with headers and 

with the following fields populated for each employee:  employee id, last name, first name, 

sequence number, cycle gross, state salary, local salary, other salary, contract months, number of 

pay periods, class code, TRS service indicator, pay location and work location.  However, the gross 

data account columns and corresponding fields will be blank or zero in the csv file. 

  

Filter options have been selected. 
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Step Action 

12  Enter X to the left of the appropriate pay type field(s) to export.  For example, to export only 

gross data lines with a Process Type of ‘A’, enter an ‘X’ to the left of ‘Type A’. 

Valid selections include:  

 Salary 

 Hourly  

 Daily 
 A - Daily/Hourly adjustment, no pension  

 B - Salary adjustment, no pension 

 X - Daily/Hourly, with FICA, NO pension/annuities or tax calculation 

 Y – Salary, with FICA, NO pension/annuities or tax calculation 

 Q - Salary adjustment with taxes and pension 

 P - Daily/Hourly adjustment with taxes and pension  

 Z - Pension adjustment only 

13  Select  (Enter - continue) to continue.  

“* * Processing Request * *” briefly displays. 

The following screen displays: 

 

  



PCGenesis Payroll System Operations Guide 

Georgia Department of Education 

June 17, 2016  2:17 PM  Page 11 of 45 

All Rights Reserved. 

Step Action 

14  Select  (F16 - Exit) to return to the Payroll System Master Menu, or select  

(Master) to return to the Business Applications Master Menu. 

At this point, PCGenesis creates the GROSSEXP.csv file and exports pertinent payroll 

information into a Microsoft® Excel comma delimited (*.csv) file. 
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B2. Saving the Gross Data .csv File as a Microsoft® Excel 

Spreadsheet/Workbook 

* * * Attention* * * 

To preserve the integrity of the GrossDat.csv file, PCGenesis users must first save the template as a 

Microsoft® Excel spreadsheet/workbook with a filename other than “GrossData.csv”. 

Based on the version of software used, file extensions such as Excel Workbook (*.xlsx), Excel 97-2003 

Workbook (*.xls), Comma delimited (*.csv), and Excel 97-2003 Template (*.xlt), for example, may 

contain descriptions that differ from this document’s instructions.  Ensuring that the filename description 

selected, such as “Workbook”, “Spreadsheet”, and “.csv File” for example, corresponds to the file type 

indicated within the instructions prevents additional processing errors. 

Step Action 

1  Within Microsoft® Excel, navigate to C:\GROSSDAT.csv. 

When selecting an alternate output location or path, navigate to that location and select the 

file used. . 

The following window displays: 

 

Step Action 

2  Select GROSSEXP.csv, and select  (Open). 
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The following window displays: 

 

Step Action 

3  Use the Scrollbar’s slider/arrow to navigate to the right-farthest spreadsheet columns. 

Scroll 

Bar 

Slider/

Arrows 
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The following window displays: 

 

Step Action 

4  Continue to slide the Scrollbar’s slider/arrow to navigate to the right-farthest spreadsheet 

columns. 

 

  



PCGenesis Payroll System Operations Guide 

Georgia Department of Education 

June 17, 2016  2:17 PM  Page 15 of 45 

All Rights Reserved. 

The following window displays: 

 

 

Step Action 

5  Verify the format of the file matches the specifications in Appendix A:  Payroll Gross Data 

Import .csv File Layout. 

6  To save the file as a Microsoft® Excel spreadsheet:  From the Menu Bar, select File → 

Save As. 

Saving the file initially as a Microsoft® Excel spreadsheet/workbook simplifies making 

modifications for PCGenesis users. 

7  Select the Drop-Down Selection icon   in the Files of type field, and select Microsoft 

Excel Worksheet (*.xls). 

8  Verify the filename is GROSSEXP.xls, and select  (Save). 
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Step Action 

Steps 9 – 23 are optional 

9  (Optional) To select the appropriate columns simultaneously:  Hold down the Ctrl key 

and select columns K - O, and Y – AB, and AE - AH. 

PCGenesis highlights the columns after they are selected. 

10  (Optional) With the columns selected, from the Menu Bar, select Format → Cells. 

11  (Optional) Select the Number Tab, and select Number from the Category: column. 

12  
(Optional) Enter 2 (0.00) in the Decimal places: field. 

13  (Optional) Verify the Use 1000 Separator (,) option is deselected. 

14  (Optional) Select the -1234.10 option in the Negative numbers (decimal format) field. 

15  (Optional) Select  (OK). 

With the completion of this step, the amount fields now contain two decimal places (0.00). 

16  (Optional) Select Column J (Pay Rate) and Column AA (GHI Dist %), and format the 

column for four decimal places. 

17  (Optional) Select Row 1 by selecting the number 1. 

18  (Optional) With Row 1 selected, from the Tool Bar, select  (Bold) and  (Center). 

19  (Optional) To select the entire spreadsheet:  Select the cell in the farthest left corner of the 

spreadsheet. 

20  (Optional) From the Menu Bar, select Format → Column → Autofit Selection. 

21  (Optional) Select Cell A3.2.  

22  (Optional) To keep Row 1 – Column Headings always visible:  From the Menu Bar, 

select View → Freeze Top Row. 

23  
(Optional) To save the formatting changes:  From the Menu Bar, select  (File 

→ Save), or select  (Save). 
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Step Action 

24  Within the Microsoft® Excel spreadsheet: 

 Delete “Inactive” employees, and add “New” employees’ information. 

 Modify Active employees’ information to update account codes and pay amounts where 

applicable. 

 Enter the pay rate for hourly and daily employees. 

Do not make entries in the REGHRS and OVTHRS columns.  If entries other than 0.00 exist 

in the columns, PCGenesis automatically calculates the gross amount during the file’s 

import. 

Complete Steps 25 – 28 before attempting to import the Gross Data information into PCGenesis. 

25  To save the file as a Microsoft® Excel spreadsheet:  After verifying all entries are correct, 

from the Menu Bar, select File → Save to save the file as a Microsoft® Excel spreadsheet 

(*.xls). 

Refer to Appendix A: Payroll Gross Data Import File Layout for assistance, where 

applicable. 

26  To save the file as a Comma delimited file:  From the Menu Bar, select File → Save as.  

Select the drop-down selection icon  within the Files of type field, and choose CSV 

(Comma delimited) (*.csv).   

27  Change the filename to GROSSDAT in the File name field, and select  (Save). 

*** Processing Request ***  Please Wait.” briefly displays. 

The following dialog box displays: 

 
 

Step Action 

28  Select  (Yes). 

29  Close Microsoft® Excel. 
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The following dialog displays: 

 

Step Action 

30  Select  (No). 

The Step 25 – 28 instructions saved these file changes. 
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Procedure C:  Using the Microsoft® Excel Payroll Gross Data 

Import Procedure to Set Up Employees for the New Fiscal Year 

C1. PCGenesis and Microsoft® Excel File Verification 
Step Action 

1  Verify the August payroll is complete. 

This procedure imports data for all active, salaried employees, not just 9-month 

employees. 

 

C2. Perform a PCGenesis Disk to Disk Backup 
Step Action 

1  From the PCGenesis server, perform a Disk-to-Disk backup: 

 Verify all users all logged out of PCGenesis. 

 Perform a PCGenesis full backup to CD or DVD or tape. 

2  Label the backup “MM/DD/CCYY – Backup Before Payroll Gross Data Import”. 
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C3. Importing the Microsoft® Excel .csv File into PCGenesis 
The Payroll Gross Data Import option sorts the Gross Data Import File by Employee ID Number 

before loading the data into the PCGenesis Update/Display Gross Data screen.  Without the sort, if the 

csv import file is not  in order by Employee ID Number, the ‘R’ replace function will only load the last 

gross data line for the employee in the import file and will lose any other gross data lines in the file. 

With the sort, all gross data lines for an employee are loaded properly. 

NOTE:  The Gross Data Import File must not be open in any application before executing the Payroll 

Gross Data Import procedure.  The import file must be closed so that PCGenesis can sort the file before 

loading the data.  

 
 

Step Action 

1  If the Gross Data Import File is open in any application, close the file before executing the 

Payroll Gross Data Import procedure.   

The import file must be closed so that PCGenesis can sort the file before loading the data. 

2  Select  (F13 - Special Functions Menu). 
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The following screen displays: 

 

Step Action 

3  Select  (F8 - Payroll Export/Import Menu). 
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The following screen displays: 

 

Step Action 

4  Select  (F2 - Payroll Gross Data Import). 
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The following screen displays: 

 

  



PCGenesis Payroll System Operations Guide 

Georgia Department of Education 

June 17, 2016  2:17 PM  Page 24 of 45 

All Rights Reserved. 

Step Action 

5  Enter the Input the GROSS DAT Type for Import field.  Valid values are: 

R - To replace ALL current entries 

A - To add salary, hourly or daily entries  

S - To add entries for substitutes 

September Account and Salary Rollover:  Enter ‘R’ in the field to replace all gross data 

entries.   

 For S (Salary) lines, PCGenesis validates the Regular Gross Amount is loaded, and 

the Cycle Gross and Contract Amount entries are loaded.   

 For H (Hourly) and D (Daily) lines, pay rates are loaded.  If regular and overtime 

hours and a Pay Rate are present, the regular and overtime amounts are calculated.  If 

the information is missing, these values will be set to zero. 

 For S (Salary) lines, PCGenesis loads the following data fields only for the Sequence 

Number 01: Cycle Gross, State Salary, Local Salary, Other Salary, Total Contract 

Amount, and TRS Service Indicator.    

To add the import file’s entries to the employee’s existing gross data:  Enter ‘A’ in the 

field.  Use this code to load a file of supplements, stipends, or other special one-time pay 

amounts.  Any type line can be added, including H, D, S, A, B, X, Y, Q and P.  Hourly and 

Daily rates and hours are loaded and the Regular and Overtime gross pay are calculated.   

To import Substitutes’ gross pay:  This feature operates the same as the Replace (‘R’) 

function, except that an extra validation is performed to insure the employee’s Pay Class is a 

“Substitute” pay class.  PCGenesis halts the Import procedure if an employee is included in 

the import file whose pay class is not “Substitute”.  When completed successfully, 

PCGenesis clears existing gross data entries for the substitute employees. 

6  Verify the path and filename have defaulted correctly as C:\GROSSDAT\GROSSDAT.csv, 

or enter the correct path and filename in the Enter the Export file Path and Name field , or 

select  (F10 - Browse to select file) to browse for the correct filename. 

PCGenesis allows entries other C:\GROSSDAT\GROSSDAT.csv as long as the directory 

structure entered exists. 

7  Select  (Enter - continue) to continue. 

“* * Processing Request * *” briefly displays. 

 

  



PCGenesis Payroll System Operations Guide 

Georgia Department of Education 

June 17, 2016  2:17 PM  Page 25 of 45 

All Rights Reserved. 

For file import errors, the following screen displays: 

 

For successful file imports with warnings, the following screen displays: 
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Step Action 

8  For file import errors:  Select Enter (to Exit Program and Correct). 

For successful file imports with warnings:  Select  (F8 – Process File ‘As Is’) to 

continue importing the file, and then proceed to Step 9.  Or, select  (F16 – Exit and 

Correct) to review the print file and correct the warnings. 

For successful file imports with no warnings:  Skip to Step 9. 

For successful file imports with no warnings, the following screen displays: 

 

Step Action 

9  Select  (ENTER – to load GROSS DATA Import File) to import the file.   

Select  (F16 – STOP Process) to stop the import process and exit the program.  

“*** Processing – Please Wait ***” briefly displays. 
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The following screen displays: 

 

Step Action 

10  To print the report via the Uqueue Print Manager:  Select  (Uqueue). 

To print the report via Microsoft® Word:  Select  (MS WORD). 

Follow the instructions provided in the Technical System Operations Guide, User Interface 

Procedures, Creating the Microsoft®-PCGenesis QWORD Macro for Report Printing to 

create the macro necessary to use the feature where appropriate. 

11  Select  (F16 - Exit) to return to the Payroll System – Special Functions Menu, or 

select  (Master) to return to the Business Applications Master Menu. 

12  Identify and correct all errors within the GROSSDAT.xls file.  Save the file as a .csv 

(Comma delimited) (csv) file, and repeat this procedure. 

Refer to Appendix A: Payroll Gross Data Import File Layout and to Appendix B:  Gross 

Data Import File Error Processing for additional error message examples, and for 

additional information to aid in the correction of errors. 

Using the Section B:  Payroll Update Processing, Topic 4:  Update/Display Payroll 

Information instructions, review the import file’s gross data information to verify the 

information is correct.  Contact the Technology Management Customer Support Center for 

assistance as needed. 
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C3.1. PCGenesis Gross Data Import Error/Warning Report - 

Example 
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Procedure D:  Using the Microsoft® Excel Template to 

Manually Create an Employee’s Gross Data/Payroll 

Information File 
PCGenesis provides a Microsoft® Excel template file, GrossImport.xlt, which allows users to create a 

file of employees’ gross data.  The instructions allow the import of gross data for the following 

employees and circumstances: 

 Thirteen (13) pay employees 

 Substitute employees, including third-party software information 

 Stipends and other one-time special payroll amounts 
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D1. Installing the GrossImport.xlt Template 
Step Action 

1  Access and open the GrossImport.xls file located at:   

Payroll System Operations Guide, Section I: Special Functions, Topic 8: Payroll Export 

and Import File Processing, PCGenesis Gross Data Import Template. 

 

The following window displays: 

 

Step Action 

2  From the Menu Bar, select File  Save As. 

3  Navigate to C:\GROSSDAT. 

4  Within the Save as type field, verify the selection of, or select Excel Template (*.xlt). 
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The following window displays: 

 

Step Action 

5  Enter GrossImport in the File name field and select  (Save). 

6  Within the Personal Computer’s (PC’s) Microsoft® Templates folder, copy the Template 

to each workstation in which PCGenesis users will create and export gross data. 

This folder is usually located on the PC at C:\OS\Profiles\user_name\Application 

Data\Microsoft\Templates, where “OS” is the operating system’s folder, e.g. WINNT or 

WINDOWS. 

Contact the local Technology Specialist for assistance as needed.  When saved to this 

location, the Template files displays on the General tab when selecting File  New. 

7  Within Microsoft® Excel, select File  New (My Templates). 
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The following window displays: 

 

 

Step Action 

8  Select GrossImport.xlt. 

A blank spreadsheet will be created with the appropriate headings and formatting. 
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The following window displays: 

 

 

Step Action 

9  Proceed to the appropriate topic based on the use of this Template. 

Gross Data 

Pay Type 

Information 

S, B, Y, Q  Adjustment line types B, Y, and Q require a Pay for Period End Date 

(PERENDDT).   

 Overtime Gross (OVT GR) is only valid for gross types S, B, Y and Q. 

 PCGenesis ignores the following fields and sets these entries to zero: 

o Regular Hours (REGHRS)  

o Overtime Hours (OVTHRS)  

o Pay Rate (PAYRATE)  

o Overtime Gross (OVT GR) 

10  D, H, A, X, P  Adjustment line types A, X, and P require a Pay for Period End Date 

(PERENDDT). 

 PCGenesis ignores the following fields, and instead calculates these 

entries from the Pay Rate, and Regular Hours (REGHRS) and Overtime 

Hours (OVTHRS) field entries: 

o Regular Gross (REG GR)  

o Overtime Gross (OVT GR)  
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D2. Importing 13-Pay Employees’ Gross Data Using the 

GrossImport.xlt Template 
Step Action 

1  Create the employees’ records in the PCGenesis Payroll system as they are hired: 

Make the appropriate entries within the Total Contract Amount, Cycle Gross, State, 

Local, and Other amounts fields. 

2  Create a Microsoft® Excel GrossImport.xlt Spreadsheet for 13-Pay employees: 

 Using the instructions in Procedure D: Using the Microsoft® Excel Template to 

Manually Create an Employee’s Gross Data/Payroll Information  create a 

Microsoft® Excel spreadsheet containing only the employees whose salaries are 

spread over thirteen (13) months. 

 Enter the employees’ names and employee numbers exactly as the information the 

information exists within the PCGenesis Payroll module. 

 Enter Process Type (GRTYPE) = S, PayRate = 0, and enter the RegHrs and 

OvtHrs fields. 

 Enter 1/13
th

 of the employees’ annual salary in the Regular Gross column. 

 Enter the appropriate amount in the Contract where applicable. 

 Enter the appropriate payroll account number in the fields. 

 Enter the appropriate GHI distribution percentage in the GHI DIST % column. 

3  Save the GrossImport.xlt Spreadsheet for 13-Pay Employees as an .XLS 

Worksheet/Spreadsheet 

 From the Menu Bar, select File → Save as.  Navigate to and open the appropriate 

file. 

 Select the Drop-Down Selection icon     in the Files of type field, and select 

Microsoft Excel Worksheet (*.xls). 

 Enter the appropriate filename, for example, GROSSDAT_13Pay, in the File name 

field and select  (Save). 

4  Save the GrossImport.xlt Spreadsheet for 13-Pay Employees as a .csv File 

 From the Menu Bar, select File → Save as.  Navigate to and open the appropriate 

file. 

 Select the Drop-Down Selection icon    in the Files of type field, and select CSV 

(Comma delimited) (csv). 

 Enter the appropriate filename, for example, GROSSDAT_13Pay, in the File name 

field and select  (Save). 

 When the GrossData.csv may contain features that are not compatible with CSV 

(Comma delimited) dialog box displays, select  (Yes). 
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Step Action 

5  Refer to C3. Importing the Microsoft® Excel .csv File into PCGenesis for instructions for 

importing the .csv file into PCGenesis. 

 Load this spreadsheet after the July payroll but before the August payroll is run.  

Import the spreadsheet either before or after Payroll Setup. 

 On the Identify Gross Data Import File from Excel screen, enter R (Replace) in the 

Input the GROSS DAT for Import field. 
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D3. Loading Substitute Employees’ Payroll Using the 

GrossImport.xlt Template 
The PCGenesis Gross Data Import procedure allows employees’ gross data to be imported from third-party 

software packages as long as the file meets PCGenesis file import requirements.  If the school district or the 

system uses a third-party software package to manage substitute employees’ pay, contact the vendor for 

instructions for importing data from the vendor’s software application. 

Step Action 

1  Create the employees’ records in the PCGenesis Payroll system as they are hired. 

2  Create a Microsoft® Excel GrossImport.xlt Spreadsheet for Substitute Employees: 

 Using the instructions in Procedure D: Using the Microsoft® Excel Template to 

Manually Create an Employee’s Gross Data/Payroll Information, create a Microsoft® 

Excel spreadsheet containing only the substitute employees’ information who worked for 

the pay period. 

 Enter the employees’ names and employee numbers exactly as the information exists 

within the Payroll module. 

 Enter Process Type (GRTYPE) = D (Daily), H (Hourly), or the pay type normally used: 

D (Daily) 

 Enter PayRate = Daily Rate, RegHrs = Total Days Worked, OvtHrs = 0.   

 Enter 0.00 in the Reg Gr column. 

 Enter the payroll account number in the fields. 

 Enter the GHI distribution percentage in the GHI DIST % column. 

H (Hourly) 

 Enter PayRate = Hourly Rate, RegHrs = Total Hours Worked, OvtHrs = Total 

Overtime Hours Worked and Reg Gr = 0 (Regular Gross is automatically calculated 

by PCGenesis). 

 Enter the payroll account number in the fields. 

 Enter the GHI distribution percentage in the GHI DIST % column. 

OVT GR is only valid for salary types S, B, Q and Y. 

3  Save the GrossImport.xlt Spreadsheet for Substitute Employees as an .XLS 

Worksheet/Spreadsheet 

 From the Menu Bar, select File → Save as.  Navigate to and open the appropriate file. 

 Select the Drop-Down Selection icon    in the Files of type field, and choose 

Microsoft Excel Worksheet (*.xls). 

 Enter the appropriate filename, for example, GROSSDAT_Substitutes, in the File 

name field and select  (Save). 
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Step Action 

4  Save the GrossImport.xlt Spreadsheet for Substitute Employees as a .csv File 

 From the Menu Bar, select File → Save as.  Navigate to and open the appropriate file. 

 Select the drop-down selection icon    to the right of Files of type and select CSV 

(Comma delimited) (csv). 

 Enter the appropriate filename, for example, GROSSDAT_Substitutes, in the File 

name field and select  (Save). 

 When the GrossData.csv may contain features that are not compatible with CSV 

(Comma delimited) dialog box displays, select  (Yes). 

5  Refer to C3. Importing the Microsoft® Excel .csv File into PCGenesis for instructions on 

importing the .csv file into PCGenesis. 

 Load this spreadsheet after Payroll Setup. 

 On the Identify Gross Data Import File from Excel screen, enter A (Add) in the Input 

the GROSS DAT for Import field. 
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D4. Loading Stipend and Other One-Time Special Payroll 

Information Using the GrossImport.xlt Template 
Step Action 

1  Create the employees’ records in the PCGenesis Payroll System module as they are hired. 

2  Create a Microsoft® Excel GrossImport.xlt Spreadsheet for Employees Affected: 

 Using the instructions in Procedure D: Using the Microsoft® Excel Template to 

Manually Create an Employee’s Gross Data/Payroll Information, create a Microsoft® 

Excel spreadsheet containing only the affected employees’ information. 

 Enter the employees’ names and employee numbers exactly as the information exists in 

Payroll. 

 Enter the appropriate pay type in the Proc Type (GRTYPE) field.   

 For example, a Proc Type of B (Salary Adjustment, No Pension) would contain the 

following entries: 

o PayRate = 0, RegHrs = 0, OvtHrs = 0, and RegGross = Stipend/Special Pay 

dollar amount. 

o Enter the appropriate payroll account number in the fields. 

o Enter the appropriate GHI distribution percentage in the GHI DIST % column. 

3  Save the GrossImport.xlt Spreadsheet for Affected Employees as an .XLS 

Worksheet/Spreadsheet 

 From the Menu Bar, select File → Save as.  Navigate to and open the appropriate file. 

 Select the Drop-Down Selection icon    in the Files of type field, and select 

Microsoft Excel Worksheet (*.xls). 

 Enter the appropriate filename, for example, GROSSDAT_Stipend, in the File name 

field and select  (Save). 

4  Save the GrossImport.xlt Spreadsheet for Affected Employees as a .csv File 

 From the Menu Bar, select File → Save as.  Navigate to and open the appropriate file. 

 Select the Drop-Down Selection icon    in the Files of type field, and select CSV 

(Comma delimited) (csv). 

 Enter the appropriate filename, for example, GROSSDAT_Stipend, in the File name 

field and select  (Save). 

 When the GrossData.csv may contain features that are not compatible with CSV 

(Comma delimited) dialog box displays, select  (Yes). 
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Step Action 

5  Refer to C3. Importing the Microsoft® Excel .csv File into PCGenesis for instructions for 

importing the .csv file into PCGenesis. 

 Load this spreadsheet after Payroll Setup. 

 On the Identify Gross Data Import File from Excel screen, enter A (Add) in the Input 

the GROSS DAT for Import field. 

6  Close Microsoft® Excel and PCGenesis, where appropriate. 
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Appendix A:  Payroll Gross Data Import .csv File Layout 
 

ATTENTION: 

The first record for each employee must contain data for all of the fields within this table.  The 30-

digit account number must be a valid account number within the current fiscal year’s BUDGET file. 

Column 
Field 

Name 

Description 

A LINE 

TYPE 

Must be “G” to indicate the line is a Gross Data import line.  PCGenesis 

ignores lines without a “G”, such as headers. 

B EMPNO Employee number.  The employee must be active in the Payroll file. 

C LNAME Employee’s last name.  The employee’s last name must match the name in the 

Payroll file. 

D FNAME Employee’s first name.  The employee’s first name must match the name in 

the Payroll file. 

E SEQ Sequence Number.  Gross data sequence line number.  (Optional, may be 

zero.) 

When the R (Replace) option is selected for the import and S (Salary) lines are 

present, PCGenesis loads the following data fields for the Sequence Number 

01: Cycle Gross, State Salary, Local Salary, Other Salary, Total Contract 

Amount, and TRS Service Indicator. 

PCGenesis automatically generates the Sequence Number when a sequence 

number is not entered. 

F GRTYPE Gross Type or Process Type code.  Salary (S), Hourly (H), Daily (D), or 

Adjustment line types A, B, X, Y, Q, P, and Z. 

Valid values:  

Regular Gross Types: 

S – Regular salary with pension and taxes 

D – Regular daily with pension and taxes 

H – Regular hourly with pension and taxes 

Special Gross Types: 

A –Daily/Hourly adjustment NO pension calculation 

B –Salary adjustment NO pension calculation 

X –Daily/Hourly, with FICA, NO pension/annuities or tax calculation 

Y –Salary, with FICA, NO pension/annuities or tax calculation 

Q –Salary adjustment with taxes and pension calculation 

P – Daily/Hourly adjustment with taxes and pension calculation 

Z – Pension adjustment only 
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Column Field Name Description 

G PAYTYPE Pay Type code.  Optional.  The Pay Type code is used only for the new 

detailed pay stub.  The Pay Type code must be defined in the payroll 

Description File.  Zero, or an empty cell, defaults to ‘000’ (Regular Pay).   

The new detailed check stub contains a new section of data entitled Current 

Hours and Earnings.  The current earnings will print based upon the Pay 

Type entered for the gross data line.  The Current Hours and Earnings 

section on the detailed check stub will list the pay type descriptions, along 

with the pay rates, regular and overtime hours, regular and overtime pay, 

and contract amounts.   

In order to get a proper breakdown of the earnings, users will need to 

categorize their employees’ Gross Data earnings by Pay Type before 

utilizing the new detailed pay check statement.  All gross data lines with the 

same Pay Type and Pay Rate will be summarized (and accumulated) on 

ONE earning line on the check stub. 

H PAYREAS Pay Reason code.  Optional pay reason code used to define the reason for 

any pay increase or decrease.  The Pay Reason code must be defined in the 

payroll Description File.  Zero, or an empty cell, identifies “normal pay”. 

I PERENDDT Pay for Period End date.  Optional for Adjustment gross types, not 

permitted for S, D, and H gross types.  The date format must be 

CCYYMMDD.  This field indicates the period for which the adjustment 

applies.  The date CANNOT be a future date.   

J PAYRATE Pay Rate.  Employee’s rate of pay. 

K REGHRS Regular Hours.  Total regular hours worked. 

L OVTHRS Overtime Hours.  Optional.  Total overtime hours worked. 

M REG GR Regular Gross.  Regular Gross amount charged to this account number.  

The accumulated total of the REG GR amount should equal the accumulated 

total of the employee’s CYCLE GR (Cycle Gross) amount. 

N OVT GR Overtime Gross.  Optional.  Overtime Gross amount charged to this 

account number.   

O CONTRACT Contract Amount.  Optional.  Current pay to going toward the annual 

Contract Amount. 

P FY Fiscal Year in this account number in which salary is charged - must be the 

valid fiscal year. 

Q FND Fund in this account number in which salary is charged 

R F Fiscal Year in this account number - always zero. 

S PRGM Program in this account number in which salary is charged. 

T FNCT Function in this account number in which salary is charged. 
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Column Field Name Description 

U OBJCT Object in this account number in which salary is charged. 

V FCTY Facility in this account number in which salary is charged. 

W B Building in this account number in which salary is charged. 

X ADDL Additional Local numbers in this account number in which salary is 

charged. 

Y PENS GR Pension Gross amount charged to this account number.  Amount of pension 

gross used for calculations of employer pension contributions.  This field 

only applies to a GRTYPE (Gross Type) of 'Z' (pension adjustment only).  

A PENS GR amount will only be accepted for an employee whose pension 

code on the Update/Display Gross Data screen is 1, 2, 3, 4, or 5.  Negative 

amounts are allowed for pension adjustments. 

Z PENS AMT Pension Amount.  The employee pension contribution adjustment amount 

charged to this account number.  This field only applies to a GRTYPE 

(Gross Type) of 'Z' (pension adjustment only).  A Pension Amount will 

only be accepted for an employee whose pension code on the 

Update/Display Gross Data screen is 1, 2, 3, 4, or 5.  Negative amounts 

are allowed for pension adjustments. 

AA GHI DIST % GHI Distribution Percentage.  Enter the GHI distribution percentage for 

the corresponding General Ledger account number.  The GHI distribution 

percentage indicates the percentage of the employer GHI contribution to 

distribute to this GL account line.  The GHI distribution percentage is valid 

only with Process Types ‘H’, ‘D’, or ‘S’. 

All GL accounts must add to 100%.  (1.0000 equals 100%, 0.2500 equals 

25%)  Distribute the employer GHI contribution across multiple account 

lines when charging GHI to multiple state programs. 

The GHI distribution percentage must be zero if the GHI Participation 

Switch is ‘N’, and the GHI Option field is NC (No Coverage) or NE (Not 

Eligible).  An employer contribution will NOT be billed for employees with 

a GHI Option field of NC (No Coverage) or NE (Not Eligible), and 

therefore, the GHI Dist field must be zero. 

PCGenesis does not allow the entry of negative percentages. 

AB CONTRAMT Contract salary amount.  The contract salary amount charged to this 

account number must equal STATE + LOCAL + OTHER salaries.  Enter the 

employee’s gross salary amount that is going towards the employee’s 

annual contract salary in the CONTRAMT field. 

When the R (Replace) option is selected for the import and S (Salary) lines 

are present, PCGenesis loads the following data fields only for the 

Sequence Number 01: Cycle Gross, State Salary, Local Salary, Other 

Salary, Total Contract Amount, and TRS Service Indicator.   

PCGenesis does not allow the entry of negative amounts. 
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Column Field Name Description 

AC SUB DIST Substitute Distribution Flag.  The Substitute Distribution field is used 

with the Enhanced Substitute Pay and Employee Leave System.  This field 

indicates whether or not a substitute’s pay is distributed to this account 

line.  Typically, the substitute’s pay is distributed to some or all of the 

absent employee’s salary (S) account lines. 

Valid values: Y = Distribute substitute pay to this account line 

  N = Do NOT distribute substitute pay to this account line 

The Substitute Distribution field is used when the Enhanced Substitute Pay 

and Employee Leave System is enabled on the Tax/Withholding/Control 

Menu. 

AD BUDG FLAG Budget Flag.  The Budget Flag field is used with the PCGenesis Budget 

System.  The Budget Flag field on each account line determines what 

formulas are applied to generate new salary amounts in the budget 

SANDBOX directory. 

Valid values:  

A =  Move the account number over to the budget, but do NOT bring 

over any amounts. 

L =  Budget as a local supplement/extra salary.  Apply either an amount 

or percent increase or decrease to the line salary or the line rate. 

M =  Move the account line over to the budget, but do NOT apply any 

increase or decrease to the line amount. 

N =  Budget as state salary, but do not apply a salary schedule.  Apply 

either an amount or percent increase or decrease to the line salary or 

the line rate.  (Usually used for non-certified employees) 

S =  Budget as state salary using the state CPI salary schedule.  (Used 

for the ‘S’ account lines of certified employees only) 

T =  Budget as local supplement using a local salary schedule.  (Used for 

the ‘S’ account lines of certified employees only) 

X =  Do not bring the account line over to the budget process.  

(Generally used for substitute pay, etc.) 

AE CYCLE GR Cycle Gross.  The cycle gross amount must equal the employee’s 

CONTRACT salary divided by the number of pay periods.  PCGenesis 

does not allow the entry of negative amounts. 

When the R (Replace) option is selected for the import and S (Salary) lines 

are present, PCGenesis loads the following data fields only for the 

Sequence Number 01: Cycle Gross, State Salary, Local Salary, Other 

Salary, Total Contract Amount, and TRS Service Indicator.   
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Column Field Name Description 

AF STATE SAL State Salary Amount.  The portion of gross salary that comes from State 

funds.  PCGenesis does not allow the entry of negative amounts. 

When the R (Replace) option is selected for the import and S (Salary) 

lines are present, PCGenesis loads the following data fields only for the 

Sequence Number 01: Cycle Gross, State Salary, Local Salary, Other 

Salary, Total Contract Amount, and TRS Service Indicator.   

AG LOCAL SAL Local Salary Amount.  The portion of gross salary that comes from 

Local funds.  PCGenesis does not allow the entry of negative amounts. 

When the R (Replace) option is selected for the import and S (Salary) 

lines are present, PCGenesis loads the following data fields only for the 

Sequence Number 01: Cycle Gross, State Salary, Local Salary, Other 

Salary, Total Contract Amount, and TRS Service Indicator.   

AH OTHER Other Salary Amount.  The portion of gross salary that comes from 

Other funds.  PCGenesis does not allow the entry of negative amounts. 

When the R (Replace) option is selected for the import and S (Salary) 

lines are present, PCGenesis loads the following data fields only for the 

Sequence Number 01: Cycle Gross, State Salary, Local Salary, Other 

Salary, Total Contract Amount, and TRS Service Indicator.   

AM SERV Retirement service indicator.  The SERV field defines the employee’s 

Teacher Retirement System (TRS) service credit. 

Valid values:  0 = No service credit 

   1 = Service credit earned for the month  

When the R (Replace) option is selected for the import and S (Salary) 

lines are present, PCGenesis loads the following data fields only for the 

Sequence Number 01: Cycle Gross, State Salary, Local Salary, Other 

Salary, Total Contract Amount, and TRS Service Indicator.   

Column Field Name Description 

 PCGenesis exports the following fields for reference only.  PCGenesis will not import 

these fields. 

AI CONTMO Contract Months.  The total number of contract months the employee 

works. 

AJ NOPAYS Number of pays (not on Gross Data screen). 

AK CLASS Payroll class code (not on Gross Data screen). 

AL CERT Certified status (not on Gross Data screen). 

AN PAY LOC Payroll pay location code (not on Gross Data screen). 

AO WORK LOC Payroll work location code (not on Gross Data screen). 
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Appendix B:  Gross Data Import File Error Processing 

B1. Gross Data Import Error Report - Example 

 
 

B2. Gross Data Import .csv File – Example 

 

 


